
 

 

Includes and Fasteners 
Local mesh manipulation, model organization by includes, creation of fastener connections. 

Step 1: Remesh the full model with 20 mm shell mesh 
1. Open the model using File > Open > Model: and select HM-08_ae-01_00.hm. 
2. Open the Automesh panel using Mesh > Create > 2D Automesh or F12. 
3. Select the displayed surfaces.  
4. Enter an elements size of 20.0.  
5. Click the switch to automatic and verify the option is set to elems to surf comp.  

 
6. Click mesh to re-mesh the model. 

Note that because of “automatic” there was no second (interactive) stage of this panel, and 
because the original mesh was associated to the surfaces, it was replaced by the new 
mesh. 

Step 2: Check the element quality and isolate failed ones with Patch Checker 
1. Open the Check Elements panel using Mesh > Check > Elements > Check Elements or 

F10. 
2. Verify the 2-d subpanel is active. 
3. Enter 1.0 for the length < field. 

 
4. Click the length < button. 

View the HyperMesh message bar of at the bottom left giving details about the failed 
elements. 

 
5. Click save failed to store the failed elements in HyperMesh’s temporary memory. 
6. Turn on the Patch Checker toolbar using View > Toolbars > HyperMesh > Patch 

Checker. 

 



 

 

7. Verify that the selector is set to Elements . 

8. Activate Patch Checker by clicking on the icon . 
Note that the model display will jump to a detail around the first patch of elements in 
HyperMesh’s temporary memory (the ones saved just before), showing them in spherical 
clipping. 

 
9. Check the message bar to see that patch one is shown and only one patch exists 

. 
If there are additional patches, you can navigate to the next patch and increase/decrease 
the clipping radius. 

 

Step 3: Fix element quality locally by replacing nodes and adjusting distance 
1. Zoom into the highlighted elements shown in the Patch Checker view and see that there are 

two very small and flat elements, due to a very small surface patch.  
While you could solve it by fixing the geometry and then remeshing it, the fastest way – 
described here – is to manipulate elements directly, without respecting geometry, using 
replace. 

2.  Activate the replace nodes panel using Mesh > Edit > Replace Nodes.  
3. Zoom into the detail so far that you can distinguish the nodes of the small, flat elements.  
4. Click the outer node of the small elements (1) then on the inner one (2).  

 



 

 

Note that you didn’t need to change the selector button in the panel, it is switching 
automatically after selecting the first node. 

5. A warning will pop up, informing that elements will be destroyed (and automatically deleted) 
by replacing theses nodes. This is what we want, and we want to do it one more time, so to 
not get this message again, confirm with yes to All. 

 
6. Now that the two small elements are fixed (deleted) we still need to fix the remaining larger 

but flat tria-element, click the remaining node from the last operation, then click the node to 
the right at the short edge of the tria-element.  
The node will be replaced and the collapsing element deleted with no further warning 
message. 
Finally, there is a quad-element remaining which has a very short edge. This can be fixed 
easiest by adjusting the node position using distance: 

7. Open the Distance panel using Mesh > Check > Nodes > Distance. 
8.  Select N1 and N2 in the order shown in the image. 

 
9. Enter 10.0 in the field of distance =.  

N2 is adjusted to a distance of 10.0 to N1. 

Step 4: Delete elements and geometry that will be replaced by new Part 
1. Turn off the Patch Checker by clicking on the wrench symbol . 
2. Activate the IC3-delete view in the Model Browser. 

3. Click the Selector  icon in the Model Browser to activate it.  
4. Select the IC3_MS component in the display area. 
5. Right-click on IC3_MS and click Delete from the dialogue. 



 

 

6. Confirm the message. See that the elements and surfaces disappear. 

 
Find and delete unused Properties and empty Assemblies by deleting the elements of IC3_MS 
along with the property that is not used by any element anymore. Additionally, an Assembly that 
referenced this Component is empty now. 
To clean up the model, use Unused and Empty in the RMB-menu of the Model Browser 
7. Right click on the Properties folder and click Unused.  
8. In the dialog box, check the box of the unused property that was found and click Delete to 

remove the property. 

 
9. Right click on the Assembly Hierarchy folder and click Empty. 
10. Select the empty component and click Delete. 
11. A new HyperMesh model can now be imported to replace the part. Click File > Import > 

Model to open the Import tab. 
12. Select the model HM-04_ae-01_08.hm from the list. 

A new meshed part appears where IC3_MS was deleted. 

Step 5: Check Assembly Structure 
1. Check the Assembly Hierarchy in the Model Browser.  

See that by importing the HyperMesh file you find the assembly IC3_rev01 from that file in 
the Hierarchy, as well as the component Middle Surface, which is not referenced by any 
assembly.  



 

 

 
2. To review the model and find what was imported right click and select Isolate to display 

only the imported part. 
You could use drag + drop to organize the assemblies and components – not done here. 

Step 6: Check the property and assign the material to the new part 
To be able to use the Fastener tool in correctly (but also to have all elements defined fully) all 
elements that will be connected need to have a material assigned. The new part imported in the 
last step has a PSHELL property, but no material assigned. 

1. Open the Properties View  in the Model Browser. 
2. Activate the Selector and click on the newly imported part in the display. 

Its property is highlighted in the browser list and property details are shown in the entity 
editor. 

3. Click twice on the Material field to open the selection dialog. 
4. Select ALU-7475 from the list of materials. 

 
The property, and through it the elements, now has this material assigned. 



 

 

 

Step 7: Create and Organize Includes 
While assemblies are a way to create a structure of Components (elements and geometry) 
inside HyperMesh, you may want to use the INCLUDE keywords to generate a data structure 
that is recognized by Nastran and OptiStruct. You can do so starting from the Model Browser. 
Assuming you want to organize your structure according to longitudinal, circular and skin 
structures into separate includes, as well as properties and materials: 

1. Open the Model View  in the Model Browser. 
2. Right click in the Model Browser to open the menu and select Create > Include File.  
3. Create five includes named Longitudinal, Circular, Skin, Properties and Materials. 

 

4. Switch to the Include View . 
5. Expand the  in the list. 
6. Move materials and properties into the respective includes by dragging and dropping the full 

category onto the include name. 

 



 

 

 
Dragging and dropping can also be done for components (respectively elements and nodes), 
but in case of many of them, would be time consuming. In this case, it is easier to use the 
organize functionality. 
7. Open the organize panel using Collectors > Organize > Components.  

 
8. Click the comps selector to open the selection panel. 

 
9. Click on the comps selector to open the extended entity selection and click by assems. 

10. Click the Next button   to browse to the Frames assembly and check the box. 

 
11. Confirm the selection and leave the panel by clicking select.  
12. Click select again to return to the initial panel.  
13. For dest = select the Circular include. 
14. Verify the boxes to move nodes and elements are checked,  
15. Click move to complete the organization of the entities. 
While this was the fastest way to select and organize all circular components, (because they 
were referenced by one assembly) the easiest way to organize the remaining structures of skin 
and longitudinal structures into their respective includes is as follows: 
16. In the Include View, click on the Entities column header to sort by name,  

This moves the skin component Skin_noDoor_MS close to the includes. 
17. Drag and drop the component Skin_noDoor_MS into the include Skin. 
18. Confirm the message to move the elements and nodes. 
19. Right click on the Master Model and click Show to make sure all remaining components in 

this include are displayed. 
20. Right click on the Circular and Skin includes and click Hide to make sure all components 

that are already moved into these includes are not displayed.  
21. Verify visually that only the longitudinal structures show up in the display area now. 
22. Perform an autofit (CTRL + click MMB) to make sure nothing is outside the display area. 
23. Open the Organize panel using Collectors > Organize > Components. 
24.  Using SHIFT and dragging the LMB, draw a window to select all displayed components. 



 

 

25.  For dest = select the Longitudinal include.  
26. Click move to complete the operation. 

All components (elements, nodes) should now be sorted to the respective includes.  
27. Verify the components by right clicking on each include and click Isolate. 
28. To prepare for organization of the Fastener elements to be created, create another include, 

named Fasteners.  
29. Organize the component Rivets (currently in the Longitudinal include) into Fasteners using 

the drag and drop method or Collectors > Organize. 

Step 8: Use ID Manager to define ID rules for includes 
1. Open the ID Manager using Tools > ID Manager.  
2. Set ranges of allowed IDs inside each include of interest, as shown in the image. 
3. For the Fasteners include, right click and select Create > ID-Range for Nodes and 

Elements. 

 
The #Overflow column shows the number of entities with an ID out of the defined range.  

4. Right click on individual or multiple includes and select Correct > Overflow to renumber 
entities with IDs out of the range. 

5. Close the ID Manager dialog. 

Step 9: Create Fasteners according to the Huth Formula 
1. Open the fastener setup using Aerospace > Connections > Fastener setup. 

Use this tool (which makes use of HyperMesh’s connector technology in the background) to 
automatically create fastener connections (RBE3- CBUSH-RBE3) with stiffness according 
to Huth Formula. 

2. Switch Location to Points. 
3. Click the points selector to open the extended entity selection. 



 

 

4. Click by collector and select the Rivets collector. 
5. Click proceed to complete the selection. 
6. Select all components. 
7. Select the ALU-7475 material. 
8. Define the rest of the settings as shown in the image. – don’t forget to switch Connection 

Type to Rivets. 

 
9. Click Create to create the rivets. 
10. Optionally, open a report table to check the realized connection types including stiffnesses. 

Note that the generated elements and connectors are organized in a new component 
rivetConn_comp1, that is organized in the Fasteners include. The fasteners wer placed 
there because Fasteners was the current include, because it was the latest one created. 



 

 

Note also that the new component, as well as the new nodes and elements were 
automatically renumbered to the ID range. You can check that with Tools > ID-Manager. 

 
You can now use the Matrix Browser to Query the Fastener Stiffness. 
11. Isolate the CBUSH elements created earlier. 
12. In the Mask Browser expand the Springs/Gaps section. 

 
13. Left click on 1 to isolate spring elements. 
14. Open the Matrix Browser using Tools > Matrix Browser.  

A new tab opens with an upper and a lower section. In the lower one: 
15. In the DataSource column select HMdata. 

 
16. In the Entities column, select elements. 
17. Click Query to query the entities. 
18. With the selection panel open, select the displayed CBUSH elements (e.g. by window with 

SHIFT + LMB).  
19. Click proceed and the first column populates with element IDs and is named elements. 
20. Click on the elements columns’ header to activate that column. 



 

 

 
21. In the Datanames column, select property. 
22. Click Query. 

A new column named property appears in the Matrix Browser. 
Note: The property id may be different than the IDs shown in the model browser, due to 
internal ID handling. To show the solver id that will export to input deck, select Datanames: 
Derived_Dataname > solverID > Query. 

23. Click the property column header. 

 
24. In the Datanames column, select K1, K2, and K3. 

 
25. Click Query.  

Three new columns K1, K2, K3 appear in the matrix browser. 

Step 10: Visualize the stiffness in the graphics area 
1. Click Visualization > Contour from the menu bar of the Matrix Browser. 



 

 

 
2. In the dialog, select elements in the Entity Column label field. 

 
3. Set Column on Y to K1. 
4. Click OK to complete the operation. 

The color of the CBUSH elements should turn to the corresponding value as in the legend. 
5. Click Preferences > Graphics to open the panel. 
6. Set element handle to 1 to see the element handles and with the color of the contouring for 

K1 better. 

 
7. In the Matrix Browser tab select Visualization > Clear Contour to return to normal 

display. 

Step 11: Save the file 


